Tänään on 24.05.2018, 06:19.

Excel kysymys

Yleiseen turisemiseen muustakin kuin pelaamisesta.
Vastaa Viestiin
Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Excel kysymys

Viesti Kirjoittaja Rooney »

Jos minulla on excel-taulukossa jalkapalloliigan kauden tulosluettelo muodossa: kotijoukkue(A-F) - vierasjoukkue(A-F) - kotimaalit(X) - vierasmaalit(Y), niin kuinka saan tehtyä 1x2-jakaumat A-A, A-B jne. ottelupareille?

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Viimeksi muokannut Rooney, 11.07.2007, 03:16. Yhteensä muokattu 2 kertaa.

Minikommentit


Oliver
Avatar
Jäsen
Viestit: 1316
Liittynyt: 14.01.2003, 13:22
Pisteitä: 206
Viesti:

Viesti Kirjoittaja Oliver »

Ehkä kannattaisi laskea mieluummin näin:

Otteluparin A vs A kotimaalit=
{=keskiarvo(jos(kotijoukkue_sarake="A";jos(vierasjoukkue_sarake="A";kotimaalit_sarake;"");""))}

Kaava pitää kuitata ctrl+shift+enter, jolloin siitä tulee vektorilaskutoimitus, eli nuo aaltosulkeet ympärille. Ja nuo lähdealueet pitää olla yhtä suuret.

En sitten kokeillut toimiiko tuo.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Viesti Kirjoittaja Rooney »

Kirjoitin kaavan tähän tapaan soluun, mutta se ei toiminut.

={=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))}

Jossa,
B=kotijoukkue
C=vierasjoukkue
F=kotimaalit

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


TT
Jäsen
Viestit: 432
Liittynyt: 22.08.2003, 15:27
Pisteitä: 0
Paikkakunta: Espoo :-(

Viesti Kirjoittaja TT »

Rooney kirjoitti:Kirjoitin kaavan tähän tapaan soluun, mutta se ei toiminut.

={=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))}
=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))

Kaavan pitää olla näin kirjoitettuna, ja sitten siinä komentorivillä ollessasi painat ctrl+shift+enter ja sitten siihen ilmestyy kaavan ympärille { } merkit:

{=KESKIARVO(JOS(B1:B380="A";JOS(C1:C380="A";F1:F380;"");""))}

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Oliver
Avatar
Jäsen
Viestit: 1316
Liittynyt: 14.01.2003, 13:22
Pisteitä: 206
Viesti:

Viesti Kirjoittaja Oliver »

Jos ei toimi, niin se johtuu tuosta keskiarvofunktiosta. Eli pitää laskea ensin summa ja jakaa sitten määrällä. Nyt huomasin samalla myös, että halusit pelkät 1X2 jakaumat etkä maalikeskiarvoja 8--)

kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Tomzie
Jäsen
Viestit: 296
Liittynyt: 29.01.2004, 11:41
Pisteitä: 0
Paikkakunta: Tre

Viesti Kirjoittaja Tomzie »

Oliver kirjoitti:kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.
En oikein tiedä mitä teen väärin, mutta mä saan vaan aina vastaukseksi 0 tuosta ensimmäisestä kaavasta.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

When life hands you lemons, ask for a bottle of tequila and salt.

Minikommentit


Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Viesti Kirjoittaja Rooney »

Oliver kirjoitti:kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.
Tämä kaava oli juurikin sellainen, jota hain. Kiitos avusta :D

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Oliver
Avatar
Jäsen
Viestit: 1316
Liittynyt: 14.01.2003, 13:22
Pisteitä: 206
Viesti:

Viesti Kirjoittaja Oliver »

Tomzie kirjoitti:
Oliver kirjoitti:kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.
En oikein tiedä mitä teen väärin, mutta mä saan vaan aina vastaukseksi 0 tuosta ensimmäisestä kaavasta.
Sarakkeita ei saa merkitä tyyliin B:B vaan B1:B65536 ja lähdealueet pitää olla yhtä suuret. Siinä jotain mitkä saattaa kusta....

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Viesti Kirjoittaja Rooney »

Tomzie kirjoitti:
Oliver kirjoitti:kotivoitot=SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";jos(kotimaalisarake>vierasmaalisarake;1;0);"");""))

kotivoittojen esiintymistiheys=kotivoitot/SUMMA(JOS(B1:B380="A";JOS(C1:C380="A";1;0);""))

Molempien kuittaus ctrl+shift+enter. Molemmat kaavat voi kirjoittaa samaankin kaavaan.
En oikein tiedä mitä teen väärin, mutta mä saan vaan aina vastaukseksi 0 tuosta ensimmäisestä kaavasta.
Malli:
<TABLE BORDER="1"><TR><TH>1</TH><TH>x</TH><TH>2</TH><TH></TH><TH></TH><TH></TH><TH></TH><TH>
</TH></TR><TR><TD>
</TD></TR><TR><TD>4</TD><TD>1</TD><TD>2</TD><TD></TD><TD>A</TD><TD>A</TD><TD>2</TD><TD>1
</TD></TR><TR><TD>4</TD><TD>1</TD><TD>2</TD><TD></TD><TD>A</TD><TD>A</TD><TD>3</TD><TD>1
</TD></TR><TR><TD>4</TD><TD>1</TD><TD>2</TD><TD></TD><TD>A</TD><TD>A</TD><TD>2</TD><TD>2
</TD></TR><TR><TD>4</TD><TD>1</TD><TD>2</TD><TD></TD><TD>A</TD><TD>A</TD><TD>4</TD><TD>1
</TD></TR><TR><TD></TD><TD></TD><TD></TD><TD></TD><TD>A</TD><TD>A</TD><TD>1</TD><TD>2
</TD></TR><TR><TD></TD><TD></TD><TD></TD><TD></TD><TD>A</TD><TD>A</TD><TD>1</TD><TD>0
</TD></TR><TR><TD></TD><TD></TD><TD></TD><TD></TD><TD>A</TD><TD>A</TD><TD>0</TD><TD>2
</TD></TR><TR><TD></TD></TR></TABLE>

Kaavat (3.rivi, sarakkeet 1-3):
=SUMMA(JOS(E3:E9="A";JOS(F3:F9="A";JOS(G3:G9>H3:H9;1;0);"");""))
=SUMMA(JOS(E3:E9="A";JOS(F3:F9="A";JOS(G3:G9=H3:H9;1;0);"");""))
=SUMMA(JOS(E3:E9="A";JOS(F3:F9="A";JOS(G3:G9<H3:H9;1;0);"");""))

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Tomzie
Jäsen
Viestit: 296
Liittynyt: 29.01.2004, 11:41
Pisteitä: 0
Paikkakunta: Tre

Viesti Kirjoittaja Tomzie »

Oliver kirjoitti:Sarakkeita ei saa merkitä tyyliin B:B vaan B1:B65536 ja lähdealueet pitää olla yhtä suuret. Siinä jotain mitkä saattaa kusta....
Kaava on mullakin ihan oikein, sillä kokeilin sitä irrallisena pienessä erillisessä testiotoksessa (vrt. Rooneyn edellinen viesti). Se ei jotenkin hyväksy sitä mun analysoitavaa dataa. Jos on testitulokset ja oikea data (samalla tavalla jaettu soluihin kuin toinenkin) vierekkäin ja muutan vain kaavasta lähdealueet, niin sekään ei toimi. Olen "Format Cellsistä" yrittänyt vikaa löytää, mutta ei auta. Ennen kuin myönnän kädettömyyteni, niin syytän Exceliä, joka on Paholaisen tuotosta.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

When life hands you lemons, ask for a bottle of tequila and salt.

Minikommentit


Oliver
Avatar
Jäsen
Viestit: 1316
Liittynyt: 14.01.2003, 13:22
Pisteitä: 206
Viesti:

Viesti Kirjoittaja Oliver »

Tomzie kirjoitti:
Oliver kirjoitti:Sarakkeita ei saa merkitä tyyliin B:B vaan B1:B65536 ja lähdealueet pitää olla yhtä suuret. Siinä jotain mitkä saattaa kusta....
Kaava on mullakin ihan oikein, sillä kokeilin sitä irrallisena pienessä erillisessä testiotoksessa (vrt. Rooneyn edellinen viesti). Se ei jotenkin hyväksy sitä mun analysoitavaa dataa. Jos on testitulokset ja oikea data (samalla tavalla jaettu soluihin kuin toinenkin) vierekkäin ja muutan vain kaavasta lähdealueet, niin sekään ei toimi. Olen "Format Cellsistä" yrittänyt vikaa löytää, mutta ei auta. Ennen kuin myönnän kädettömyyteni, niin syytän Exceliä, joka on Paholaisen tuotosta.
Kokeileppa, että maalaat ne ongelmasarakkeet, paina ctrl+h ja laita etsittäväksi "" ja jätä korvattava kohta -tyhjäksi. Data on todnäk tekstinä eikä siihen aina pysty vaikuttamaan muotoilupuolelta.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Tomzie
Jäsen
Viestit: 296
Liittynyt: 29.01.2004, 11:41
Pisteitä: 0
Paikkakunta: Tre

Viesti Kirjoittaja Tomzie »

Oliver kirjoitti:Kokeileppa, että maalaat ne ongelmasarakkeet, paina ctrl+h ja laita etsittäväksi "" ja jätä korvattava kohta -tyhjäksi. Data on todnäk tekstinä eikä siihen aina pysty vaikuttamaan muotoilupuolelta.
siis pelkät hipsut? ei löytänyt mitään.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

When life hands you lemons, ask for a bottle of tequila and salt.

Minikommentit


Oliver
Avatar
Jäsen
Viestit: 1316
Liittynyt: 14.01.2003, 13:22
Pisteitä: 206
Viesti:

Viesti Kirjoittaja Oliver »

Tomzie kirjoitti:
Oliver kirjoitti:Kokeileppa, että maalaat ne ongelmasarakkeet, paina ctrl+h ja laita etsittäväksi "" ja jätä korvattava kohta -tyhjäksi. Data on todnäk tekstinä eikä siihen aina pysty vaikuttamaan muotoilupuolelta.
siis pelkät hipsut? ei löytänyt mitään.
No kokeiles korvaa kohtaan "" ja korvattavaan "xxx" ja sitten korvaa kohtaan "xxx" ja korvattavaan ""

:lol:

Tai sitten data-alueella on oikeasti ylimääräsiä merkkejä, esim. jos on copypastetettu tulokset jostain niin helposti jää välilyöntejä numeroiden perään.

Välillä Excelin toiminta on mysteeri itsellenikin, vaikka sen kanssa on tullut tapeltua jo suht paljon.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Tomzie
Jäsen
Viestit: 296
Liittynyt: 29.01.2004, 11:41
Pisteitä: 0
Paikkakunta: Tre

Viesti Kirjoittaja Tomzie »

Oliver kirjoitti:Tai sitten data-alueella on oikeasti ylimääräsiä merkkejä, esim. jos on copypastetettu tulokset jostain niin helposti jää välilyöntejä numeroiden perään.

Välillä Excelin toiminta on mysteeri itsellenikin, vaikka sen kanssa on tullut tapeltua jo suht paljon.
Joo, näyttäisi olevan välilyöntejä. Ei kuitenkaan numeroiden, vaan joukkueiden perässä. Saako niitä mitenkään poistettua muuten kuin manuaalisesti (niitä on erinäinen määrä)? Jos ei, niin voi olla, että loppuu tilastojen teko sillä kellonlyömällä (niitä on meinaan jokunen). :roll:

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

When life hands you lemons, ask for a bottle of tequila and salt.

Minikommentit


Oliver
Avatar
Jäsen
Viestit: 1316
Liittynyt: 14.01.2003, 13:22
Pisteitä: 206
Viesti:

Viesti Kirjoittaja Oliver »

Tomzie kirjoitti:
Oliver kirjoitti:Tai sitten data-alueella on oikeasti ylimääräsiä merkkejä, esim. jos on copypastetettu tulokset jostain niin helposti jää välilyöntejä numeroiden perään.

Välillä Excelin toiminta on mysteeri itsellenikin, vaikka sen kanssa on tullut tapeltua jo suht paljon.
Joo, näyttäisi olevan välilyöntejä. Ei kuitenkaan numeroiden, vaan joukkueiden perässä. Saako niitä mitenkään poistettua muuten kuin manuaalisesti (niitä on erinäinen määrä)? Jos ei, niin voi olla, että loppuu tilastojen teko sillä kellonlyömällä (niitä on meinaan jokunen). :roll:
Esim. funktiolla poista.välit.

Nää on ihan perusjuttuja, jotka löytyy helppidokkarista nopeammin kuin kysymällä. Isompia systeemejä haikailevien kantsii lukaista esim. Excel Bible tai vielä parempi Excel Power Programming with VBA. Excelillä kun voi tehdä sellaisia juttuja, että moni omia softiaan rakenteleva jannu ei tajuakaan :)

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Viesti Kirjoittaja Rooney »

Lisäkysymys vielä samaan topicciin...

Kuinka saan kopioitua solun, jossa on kaava siten, että kopioitavaan soluun ei tule kaavaa, vaan kaavan tulos?

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Fumbler
Jäsen
Viestit: 19
Liittynyt: 30.09.2005, 20:40
Pisteitä: 2

Viesti Kirjoittaja Fumbler »

Rooney kirjoitti:Lisäkysymys vielä samaan topicciin...

Kuinka saan kopioitua solun, jossa on kaava siten, että kopioitavaan soluun ei tule kaavaa, vaan kaavan tulos?
Normaalin Paste-komennon sijaan Paste Special (oliskohan ollut suomenkielisessä "Liitä Määräten") ja sieltä valinta Values.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Viesti Kirjoittaja Rooney »

Osaako joku neuvoa seuraavassa excel-pulmassa?

Kuinka saan luotua soluun soluviittauksen niin, että se säilyy sitä kopioitaessa? ("kiinteän" soluviittauksen)

Kun normaalisti kopioitaessahan tapahtuu niin, että jos kopioin esimerkiksi solua, jossa on viittaus viereiseen soluun, solun alapuolelle, myös viittaus siirtyy yhden solun alemmaksi. (B22)=C22 ----> (B23)=C23

HUOM. Muiden solussa olevien viittauksien pitääkin säilyä sellaisina, että muuttuvat kopioitaessa.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


squeeze
Jäsen
Viestit: 126
Liittynyt: 11.02.2007, 12:35
Pisteitä: 0

Viesti Kirjoittaja squeeze »

Jos haluat että vaikka B22 pysyy samana. Laitat dollarit $B$22. Helpoiten onnistuu kun laitat kursorin B:n ja 22:n väliin ja painat F4:ää.

Ilmeisesti tätä hait. Tai sitten ymmärsin väärin :D

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Rooney
Jäsen
Viestit: 675
Liittynyt: 12.04.2007, 17:30
Pisteitä: 0

Viesti Kirjoittaja Rooney »

squeeze kirjoitti:Jos haluat että vaikka B22 pysyy samana. Laitat dollarit $B$22. Helpoiten onnistuu kun laitat kursorin B:n ja 22:n väliin ja painat F4:ää.

Ilmeisesti tätä hait. Tai sitten ymmärsin väärin :D
Juuri tuota hain :D

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


jarihfi
Jäsen
Viestit: 222
Liittynyt: 14.07.2004, 23:20
Pisteitä: 3

Viesti Kirjoittaja jarihfi »

Lainaanpa vanhaa ketjua, niin tarvi turhaan tehdä uutta.

Saako Excelissä jotenkin muokattua tätä alareunan välilehdet-osiota esim. kaksikerroksiseksi ? Harmittaa vietävästi aina skrollata näillä kankeilla namiskoilla tätä palkkia edestakaisin, kun kuitenkin välilehtiä on kertynyt kohtuu mukava määrä ajan saatossa. Esim Windowsin työpöydässähän kyseisen "venyttämisen" voi tehdä ihan vain tarraamalla yläreunasta hiirulaisella kiinni ja vetämällä haluamansa korkuiseksi.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


TT
Jäsen
Viestit: 432
Liittynyt: 22.08.2003, 15:27
Pisteitä: 0
Paikkakunta: Espoo :-(

Viesti Kirjoittaja TT »

Mikäänhän ei estä sinua pienentämästä niiden välilehtien nimiä vaikkapa kahden kirjaimen pituisiksi ja voit pienentää sitä oikeassa alakulmassa olevaa vierityspalkkia aika paljon. En tiedä kuinka paljon välilehtiä kaipaat auki, mutta läppärissäni 15.4" näytölle mahtuu noin 20 välilehteä joiden nimen pituus on seitsemisen merkkiä/välilehti. 20" näytölle näyttää mahtuvan Sheet1-Sheet27 nimiset välilehdet, joten kyllä niitä ilman kahteen tasoon saamistakin aika monta saa mahtumaan.

Pisteitä

Pisteitä yhteensä: 0. Antamasi peukut: 0.

Minikommentit


Vastaa Viestiin

Palaa sivulle “Yleinen turina”